Jump to content
Heather Mills - Amputee Forum
Sign in to follow this  
kastley3

gel sleeves

Recommended Posts

hi I'm kevin I've just been given new gel sleeves and after wearing them for a few hours they started to pull my skin and when I took them off at night a lot of hair folicals were raised, red, very very itchy, and sore the more I rubbed them the worse it got it drove me mad through the night I hardly slept for itching. Dose anyone have any advise PLEASE!!!!!!!!!!

Share this post


Link to post
Share on other sites

Have you worn this type before? Were they the same material? Try using a mild lotion to soothe the skin. I will sometimes get a mild version of this even though I've used the exact same liners for years now.

Wash and rinse the liners very well before using them again.

  • Like 1

Share this post


Link to post
Share on other sites

Lots and lots of liner-washing the liner may indeed be what you need. It's not an unusual situation to have some degree of irritation when breaking in a new liner...I routinely have a few days of itchiness when I get a new one. And Neal's right...it can happen even if you've been wearing a specific type of liner for some time. Heck, I once developed a major sensitivity to a liner--an OLD liner--that I'd been wearing for several months!

Now, I never did manage to get back into that old liner (or even a new liner made of a similar material) once I'd broken out in that rash. So if a little time and a lot of cleaning doesn't clear up the problem, you may need to look into getting a liner with a different formulation. While you're seeing if you can adjust to this liner, I'd suggest trying hydrocortisone cream (NOT ointment) on the irritated skin, especially after taking the liner off at night.

Good luck!

  • Like 1

Share this post


Link to post
Share on other sites

I agree with Cherylm...same thing happened with me and I used the hydrocortisone lotion also. I knew if I didn't quit scratching I would be raw. That's a terrible feeling, isn't it. I also used a new liner {exactly the same as I had been using} Have no idea why this happened. :happy:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×